<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11">
		<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<title>Catalytic Converter &#8211; Three Letter Acronym</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Three Letter Acronym &raquo; Feed" href="https://tla.systems/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="Three Letter Acronym &raquo; Comments Feed" href="https://tla.systems/blog/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/tla.systems\/blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.3"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='twentysixteen-jetpack-css'  href='https://tla.systems/blog/wp-content/plugins/jetpack/modules/theme-tools/compat/twentysixteen.css?ver=7.8' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://tla.systems/blog/wp-includes/css/dist/block-library/style.min.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://tla.systems/blog/wp-includes/css/dist/block-library/theme.min.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='twentysixteen-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather%3A400%2C700%2C900%2C400italic%2C700italic%2C900italic%7CMontserrat%3A400%2C700%7CInconsolata%3A400&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://tla.systems/blog/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='twentysixteen-style-css'  href='https://tla.systems/blog/wp-content/themes/twentysixteen/style.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='twentysixteen-block-style-css'  href='https://tla.systems/blog/wp-content/themes/twentysixteen/css/blocks.css?ver=20181230' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='twentysixteen-ie-css'  href='https://tla.systems/blog/wp-content/themes/twentysixteen/css/ie.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentysixteen-ie8-css'  href='https://tla.systems/blog/wp-content/themes/twentysixteen/css/ie8.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='twentysixteen-ie7-css'  href='https://tla.systems/blog/wp-content/themes/twentysixteen/css/ie7.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='social-logos-css'  href='https://tla.systems/blog/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://tla.systems/blog/wp-content/plugins/jetpack/css/jetpack.css?ver=7.8' type='text/css' media='all' />
<script type='text/javascript' src='https://tla.systems/blog/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://tla.systems/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://tla.systems/blog/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20190204'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://tla.systems/blog/wp-content/themes/twentysixteen/js/html5.js?ver=3.7.3'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://tla.systems/blog/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://tla.systems/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://tla.systems/blog/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='A long time ago, in a Glasgow far, far, away&#8230;' href='https://tla.systems/blog/2017/12/23/a-long-time-ago-in-a-glasgow-far-far-away/' />
<meta name="generator" content="WordPress 5.2.3" />
<link rel="canonical" href="https://tla.systems/blog/2019/10/08/catalytic-converter/" />
<link rel='shortlink' href='https://wp.me/p9uIgl-5S' />
<link rel="alternate" type="application/json+oembed" href="https://tla.systems/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftla.systems%2Fblog%2F2019%2F10%2F08%2Fcatalytic-converter%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://tla.systems/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftla.systems%2Fblog%2F2019%2F10%2F08%2Fcatalytic-converter%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Catalytic Converter" />
<meta property="og:url" content="https://tla.systems/blog/2019/10/08/catalytic-converter/" />
<meta property="og:description" content="Catalyst is in some ways a miraculous technology &#8211; just click a check box and instantly have a working Mac version of your app. And, given the source code of a relatively modern iOS app, it c…" />
<meta property="article:published_time" content="2019-10-08T15:40:34+00:00" />
<meta property="article:modified_time" content="2019-10-09T16:35:56+00:00" />
<meta property="og:site_name" content="Three Letter Acronym" />
<meta property="og:image" content="http://tla.systems/blog/wp-content/uploads/2019/10/After-1024x757.png" />
<meta property="og:image:width" content="840" />
<meta property="og:image:height" content="621" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Catalytic Converter" />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
</head>

<body class="post-template-default single single-post postid-364 single-format-aside wp-embed-responsive">
<div id="page" class="site">
	<div class="site-inner">
		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		<header id="masthead" class="site-header" role="banner">
			<div class="site-header-main">
				<div class="site-branding">
					
											<p class="site-title"><a href="https://tla.systems/blog/" rel="home">Three Letter Acronym</a></p>
												<p class="site-description">Please, Not Another Indie Developer Blog</p>
									</div><!-- .site-branding -->

							</div><!-- .site-header-main -->

					</header><!-- .site-header -->

		<div id="content" class="site-content">

<div id="primary" class="content-area">
	<main id="main" class="site-main" role="main">
		
<article id="post-364" class="post-364 post type-post status-publish format-aside hentry category-uncategorized post_format-post-format-aside">
	<header class="entry-header">
		<h1 class="entry-title">Catalytic Converter</h1>	</header><!-- .entry-header -->

	
	
	<div class="entry-content">
		<p><a href="https://developer.apple.com/mac-catalyst/">Catalyst</a> is in some ways a miraculous technology &#8211; just click a check box and instantly have a working Mac version of your app. And, given the source code of a relatively modern iOS app, it certainly works. Even PCalc&#8217;s <a href="https://vimeo.com/337592612">About screen</a> worked out of the box.</p>
<figure id="attachment_366" aria-describedby="caption-attachment-366" style="width: 840px" class="wp-caption aligncenter"><a href="https://i0.wp.com/tla.systems/blog/wp-content/uploads/2019/10/About.png"><img data-attachment-id="366" data-permalink="https://tla.systems/blog/2019/10/08/catalytic-converter/about-2/" data-orig-file="https://i0.wp.com/tla.systems/blog/wp-content/uploads/2019/10/About.png?fit=1802%2C1450&amp;ssl=1" data-orig-size="1802,1450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="About" data-image-description="" data-medium-file="https://i0.wp.com/tla.systems/blog/wp-content/uploads/2019/10/About.png?fit=300%2C241&amp;ssl=1" data-large-file="https://i0.wp.com/tla.systems/blog/wp-content/uploads/2019/10/About.png?fit=840%2C676&amp;ssl=1" class="wp-image-366 size-large" src="https://i0.wp.com/tla.systems/blog/wp-content/uploads/2019/10/About.png?resize=840%2C676" alt="" width="840" height="676" srcset="https://i0.wp.com/tla.systems/blog/wp-content/uploads/2019/10/About.png?resize=1024%2C824&amp;ssl=1 1024w, https://i0.wp.com/tla.systems/blog/wp-content/uploads/2019/10/About.png?resize=300%2C241&amp;ssl=1 300w, https://i0.wp.com/tla.systems/blog/wp-content/uploads/2019/10/About.png?resize=768%2C618&amp;ssl=1 768w, https://i0.wp.com/tla.systems/blog/wp-content/uploads/2019/10/About.png?resize=1200%2C966&amp;ssl=1 1200w, https://i0.wp.com/tla.systems/blog/wp-content/uploads/2019/10/About.png?w=1680 1680w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 62vw, 840px" data-recalc-dims="1" /></a><figcaption id="caption-attachment-366" class="wp-caption-text">&#8220;Your developers were so preoccupied with whether or not they could that they didn&#8217;t stop to think if they should.&#8221;</figcaption></figure>
<p>But that is just step one of a much longer process.</p>
<p>I wanted to explore how feasible it would be to move <a href="https://pcalc.com/">PCalc</a> to Catalyst, but my criteria was that I would only release something that was better than the existing Mac version. It would be great if I could. Even though a lot of core logic code is shared between the different versions, most of the user interface code isn&#8217;t, so I currently have to write that twice which means less time spent on both versions.</p>
<p>For a developer without an existing Mac app, that equation is certainly a different one.</p>
<p>The &#8220;single check box&#8221; Catalyst version of PCalc is a single resizable window, with many tables and popovers that seem to me to be out-of-place on the Mac.</p>
<figure id="attachment_367" aria-describedby="caption-attachment-367" style="width: 840px" class="wp-caption aligncenter"><a href="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/PCalc-Catalyst.png"><img data-attachment-id="367" data-permalink="https://tla.systems/blog/2019/10/08/catalytic-converter/pcalc-catalyst/" data-orig-file="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/PCalc-Catalyst.png?fit=1802%2C1450&amp;ssl=1" data-orig-size="1802,1450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="PCalc Catalyst" data-image-description="" data-medium-file="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/PCalc-Catalyst.png?fit=300%2C241&amp;ssl=1" data-large-file="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/PCalc-Catalyst.png?fit=840%2C676&amp;ssl=1" class="wp-image-367 size-large" src="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/PCalc-Catalyst.png?resize=840%2C676" alt="" width="840" height="676" srcset="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/PCalc-Catalyst.png?resize=1024%2C824&amp;ssl=1 1024w, https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/PCalc-Catalyst.png?resize=300%2C241&amp;ssl=1 300w, https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/PCalc-Catalyst.png?resize=768%2C618&amp;ssl=1 768w, https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/PCalc-Catalyst.png?resize=1200%2C966&amp;ssl=1 1200w, https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/PCalc-Catalyst.png?w=1680 1680w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 62vw, 840px" data-recalc-dims="1" /></a><figcaption id="caption-attachment-367" class="wp-caption-text">It does all work though!</figcaption></figure>
<p>Things that work well with touch, don&#8217;t necessarily look or feel great. In fact, I would say that the more an app uses the standard iOS user interface elements, the less it feels right on the Mac.</p>
<p>For something like a game that is all custom UI anyway, you probably couldn&#8217;t even tell, although Catalyst currently isn&#8217;t a great fit for game developers either.</p>
<p>It became pretty clear to me that I would need to rewrite a lot of the user interface, to find a happy middle ground between the iPad and the Mac. Which would probably benefit both in the long run, to be fair. But with everything else that was going on this summer, I couldn&#8217;t justify that work, with no guarantees at the end of the day that I would have something I was happy to ship. So, I mainly focused my time on things like Shortcuts and Dark Mode, and iOS 13 support in general.</p>
<p>I decided I would commit to a Catalyst version of my &#8220;<a href="https://www.pcalc.com/itunes_store_link/dice">Dice by PCalc</a>&#8221; app. It&#8217;s a smaller app, and not so high stakes, but it still touches a lot of the OS. That would give me a feel for how well Catalyst works today.</p>
<figure id="attachment_368" aria-describedby="caption-attachment-368" style="width: 840px" class="wp-caption aligncenter"><a href="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/02.png"><img data-attachment-id="368" data-permalink="https://tla.systems/blog/2019/10/08/catalytic-converter/attachment/02/" data-orig-file="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/02.png?fit=2560%2C1600&amp;ssl=1" data-orig-size="2560,1600" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="02" data-image-description="" data-medium-file="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/02.png?fit=300%2C188&amp;ssl=1" data-large-file="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/02.png?fit=840%2C525&amp;ssl=1" class="wp-image-368 size-large" src="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/02.png?resize=840%2C525" alt="" width="840" height="525" srcset="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/02.png?resize=1024%2C640&amp;ssl=1 1024w, https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/02.png?resize=300%2C188&amp;ssl=1 300w, https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/02.png?resize=768%2C480&amp;ssl=1 768w, https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/02.png?resize=1200%2C750&amp;ssl=1 1200w, https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/02.png?w=1680 1680w, https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/02.png?w=2520 2520w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 62vw, 840px" data-recalc-dims="1" /></a><figcaption id="caption-attachment-368" class="wp-caption-text">Time to roll the dice…</figcaption></figure>
<p>And I have something that is functional, that I <a href="https://www.pcalc.com/mac_app_store/dice">shipped on day one</a>. I&#8217;m still not 100% happy with it yet though.</p>
<p>Once you get past that first check box, and want to build out Mac-specific features like menus, the APIs start to feel rougher and unfinished. For example, the ability to put images in menus only started working late in the Catalina beta cycle, and the menu APIs are not nearly as comprehensive as the underlying Mac equivalents.</p>
<p>SceneKit fails entirely on older machines with Nvidia GPUs, leading to black windows, a bug that made it all the way to Catalina GM. Multiple window support works, but I ran into a lot of problems there too. Some APIs like the share sheet are just not present.</p>
<p>There&#8217;s still no direct way to read the state of the keyboard either, so detecting that the user is holding down option as you drag something isn&#8217;t easy. That also affects games that want to offer keyboard controls. I <a href="https://www.highcaffeinecontent.com/blog/20190607-Beyond-the-Checkbox-with-Catalyst-and-AppKit">found a way through public APIs</a>, and App Review did approve the app using this technique, but it isn&#8217;t ideal by any means. Similarly for really simple things like changing the cursor.</p>
<p>Some user interface elements like the spinning carousel pickers felt especially out-of-place, and unintuitive &#8211; you can&#8217;t click and drag on them to change the value, you have to use a scroll wheel/gesture.</p>
<figure id="attachment_370" aria-describedby="caption-attachment-370" style="width: 840px" class="wp-caption aligncenter"><a href="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/Before.png"><img data-attachment-id="370" data-permalink="https://tla.systems/blog/2019/10/08/catalytic-converter/before/" data-orig-file="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/Before.png?fit=1782%2C1318&amp;ssl=1" data-orig-size="1782,1318" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Before" data-image-description="" data-medium-file="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/Before.png?fit=300%2C222&amp;ssl=1" data-large-file="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/Before.png?fit=840%2C621&amp;ssl=1" class="wp-image-370 size-large" src="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/Before.png?resize=840%2C621" alt="" width="840" height="621" srcset="https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/Before.png?resize=1024%2C757&amp;ssl=1 1024w, https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/Before.png?resize=300%2C222&amp;ssl=1 300w, https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/Before.png?resize=768%2C568&amp;ssl=1 768w, https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/Before.png?resize=1200%2C888&amp;ssl=1 1200w, https://i2.wp.com/tla.systems/blog/wp-content/uploads/2019/10/Before.png?w=1680 1680w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 62vw, 840px" data-recalc-dims="1" /></a><figcaption id="caption-attachment-370" class="wp-caption-text">Before polishing</figcaption></figure>
<p>The nearest equivalent on the Mac would be something like a popup menu button. But there&#8217;s no popup menu button on iOS, so I have resorted to writing my own &#8211; and that is <a href="https://www.youtube.com/watch?v=RWW6aDpUvbQ">one of the classic blunders</a>.</p>
<figure id="attachment_371" aria-describedby="caption-attachment-371" style="width: 840px" class="wp-caption aligncenter"><img data-attachment-id="371" data-permalink="https://tla.systems/blog/2019/10/08/catalytic-converter/after/" data-orig-file="https://i1.wp.com/tla.systems/blog/wp-content/uploads/2019/10/After.png?fit=1782%2C1318&amp;ssl=1" data-orig-size="1782,1318" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="After" data-image-description="" data-medium-file="https://i1.wp.com/tla.systems/blog/wp-content/uploads/2019/10/After.png?fit=300%2C222&amp;ssl=1" data-large-file="https://i1.wp.com/tla.systems/blog/wp-content/uploads/2019/10/After.png?fit=840%2C621&amp;ssl=1" class="wp-image-371 size-large" src="https://i1.wp.com/tla.systems/blog/wp-content/uploads/2019/10/After.png?resize=840%2C621" alt="" width="840" height="621" srcset="https://i1.wp.com/tla.systems/blog/wp-content/uploads/2019/10/After.png?resize=1024%2C757&amp;ssl=1 1024w, https://i1.wp.com/tla.systems/blog/wp-content/uploads/2019/10/After.png?resize=300%2C222&amp;ssl=1 300w, https://i1.wp.com/tla.systems/blog/wp-content/uploads/2019/10/After.png?resize=768%2C568&amp;ssl=1 768w, https://i1.wp.com/tla.systems/blog/wp-content/uploads/2019/10/After.png?resize=1200%2C888&amp;ssl=1 1200w, https://i1.wp.com/tla.systems/blog/wp-content/uploads/2019/10/After.png?w=1680 1680w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 1362px) 62vw, 840px" data-recalc-dims="1" /><figcaption id="caption-attachment-371" class="wp-caption-text">After polishing</figcaption></figure>
<p>It&#8217;s the kind of thing that Apple should supply as standard, but I get the feeling they just ran out of time. The OS releases don&#8217;t seem to have gone very smoothly in general, from my outside perspective.</p>
<p>Documentation for Catalyst has been almost non-existent too, which has made things a lot harder than they should be.</p>
<p>From the business side, there is also no way for somebody to get the Catalyst version of the app for free when they buy the iOS version. And no great way to share in-app purchases either if you have a free app. That generally means that somebody will have to pay a second time to get a copy. There is definitely an argument that building a Catalyst version is actual work, work that should be paid for, but I can equally see the side of consumers that have been told it&#8217;s just a simple check box. Apple said a shared store will come in two years, but that&#8217;s still a way off.</p>
<p>I am hopeful that this is just a 1.0 (if you count the Mojave apps as a public beta), and things will continue to improve. It&#8217;s a great foundation, but there&#8217;s still a way to go before I could use it for PCalc. The real question is, what will be the state of Catalyst vs the state of <a href="https://developer.apple.com/xcode/swiftui/">Swift UI</a> in future years? If one gains significant traction with developers, will Apple stop investing resources in the other? Time will tell.</p>
<p>For now, <a href="https://pcalc.com/dice/">buy my Dice app</a> 🙂</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-364" class="share-twitter sd-button share-icon no-text" href="https://tla.systems/blog/2019/10/08/catalytic-converter/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-364" class="share-facebook sd-button share-icon no-text" href="https://tla.systems/blog/2019/10/08/catalytic-converter/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-140307013-364-5d9e726a9c0f6' data-src='https://widgets.wp.com/likes/#blog_id=140307013&amp;post_id=364&amp;origin=tla.systems&amp;obj_id=140307013-364-5d9e726a9c0f6' data-name='like-post-frame-140307013-364-5d9e726a9c0f6'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>
<div class="author-info">
	<div class="author-avatar">
		<img alt='' src='https://secure.gravatar.com/avatar/589648381518b2328e8bcfceb3d62708?s=42&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/589648381518b2328e8bcfceb3d62708?s=84&#038;d=mm&#038;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' />	</div><!-- .author-avatar -->

	<div class="author-description">
		<h2 class="author-title"><span class="author-heading">Author:</span> James Thomson</h2>

		<p class="author-bio">
			Indie iOS / Mac developer, maker of PCalc and DragThing. Occasional writer, conference speaker, and podcast pundit.			<a class="author-link" href="https://tla.systems/blog/author/admin/" rel="author">
				View all posts by James Thomson			</a>
		</p><!-- .author-bio -->
	</div><!-- .author-description -->
</div><!-- .author-info -->
	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<span class="byline"><span class="author vcard"><img alt='' src='https://secure.gravatar.com/avatar/589648381518b2328e8bcfceb3d62708?s=49&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/589648381518b2328e8bcfceb3d62708?s=98&#038;d=mm&#038;r=g 2x' class='avatar avatar-49 photo' height='49' width='49' /><span class="screen-reader-text">Author </span> <a class="url fn n" href="https://tla.systems/blog/author/admin/">James Thomson</a></span></span><span class="posted-on"><span class="screen-reader-text">Posted on </span><a href="https://tla.systems/blog/2019/10/08/catalytic-converter/" rel="bookmark"><time class="entry-date published" datetime="2019-10-08T15:40:34+00:00">October 8, 2019</time><time class="updated" datetime="2019-10-09T16:35:56+00:00">October 9, 2019</time></a></span><span class="entry-format"><span class="screen-reader-text">Format </span><a href="https://tla.systems/blog/type/aside/">Aside</a></span><span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://tla.systems/blog/category/uncategorized/" rel="category tag">Uncategorized</a></span>			</footer><!-- .entry-footer -->
</article><!-- #post-364 -->

	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://tla.systems/blog/2017/12/23/a-long-time-ago-in-a-glasgow-far-far-away/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">A long time ago, in a Glasgow far, far, away&#8230;</span></a></div></div>
	</nav>
	</main><!-- .site-main -->

	
</div><!-- .content-area -->


	<aside id="secondary" class="sidebar widget-area" role="complementary">
		<section id="search-2" class="widget widget_search">
<form role="search" method="get" class="search-form" action="https://tla.systems/blog/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
	</label>
	<button type="submit" class="search-submit"><span class="screen-reader-text">Search</span></button>
</form>
</section>		<section id="recent-posts-2" class="widget widget_recent_entries">		<h2 class="widget-title">Recent Posts</h2>		<ul>
											<li>
					<a href="https://tla.systems/blog/2019/10/08/catalytic-converter/">Catalytic Converter</a>
									</li>
											<li>
					<a href="https://tla.systems/blog/2017/12/23/a-long-time-ago-in-a-glasgow-far-far-away/">A long time ago, in a Glasgow far, far, away&#8230;</a>
									</li>
											<li>
					<a href="https://tla.systems/blog/2016/10/03/rise-of-the-ulluminati/">Rise of the Úlluminati</a>
									</li>
											<li>
					<a href="https://tla.systems/blog/2014/03/13/state-of-mind-machine/">State (of Mind) Machine</a>
									</li>
											<li>
					<a href="https://tla.systems/blog/2010/08/03/universal-cheapness/">Universal cheapness</a>
									</li>
					</ul>
		</section><section id="recent-comments-2" class="widget widget_recent_comments"><h2 class="widget-title">Recent Comments</h2><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href='http://tla.systems' rel='external nofollow' class='url'>James Thomson</a></span> on <a href="https://tla.systems/blog/2017/12/23/a-long-time-ago-in-a-glasgow-far-far-away/#comment-357">A long time ago, in a Glasgow far, far, away&#8230;</a></li><li class="recentcomments"><span class="comment-author-link">PCalc Newbie</span> on <a href="https://tla.systems/blog/2017/12/23/a-long-time-ago-in-a-glasgow-far-far-away/#comment-356">A long time ago, in a Glasgow far, far, away&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://tla.systems' rel='external nofollow' class='url'>James Thomson</a></span> on <a href="https://tla.systems/blog/2017/12/23/a-long-time-ago-in-a-glasgow-far-far-away/#comment-350">A long time ago, in a Glasgow far, far, away&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://tla.systems' rel='external nofollow' class='url'>James Thomson</a></span> on <a href="https://tla.systems/blog/2017/12/23/a-long-time-ago-in-a-glasgow-far-far-away/#comment-349">A long time ago, in a Glasgow far, far, away&#8230;</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.ricklepage.com' rel='external nofollow' class='url'>Rick LePage</a></span> on <a href="https://tla.systems/blog/2017/12/23/a-long-time-ago-in-a-glasgow-far-far-away/#comment-344">A long time ago, in a Glasgow far, far, away&#8230;</a></li></ul></section><section id="archives-2" class="widget widget_archive"><h2 class="widget-title">Archives</h2>		<ul>
				<li><a href='https://tla.systems/blog/2019/10/'>October 2019</a></li>
	<li><a href='https://tla.systems/blog/2017/12/'>December 2017</a></li>
	<li><a href='https://tla.systems/blog/2016/10/'>October 2016</a></li>
	<li><a href='https://tla.systems/blog/2014/03/'>March 2014</a></li>
	<li><a href='https://tla.systems/blog/2010/08/'>August 2010</a></li>
	<li><a href='https://tla.systems/blog/2009/12/'>December 2009</a></li>
	<li><a href='https://tla.systems/blog/2009/10/'>October 2009</a></li>
	<li><a href='https://tla.systems/blog/2009/09/'>September 2009</a></li>
	<li><a href='https://tla.systems/blog/2009/07/'>July 2009</a></li>
	<li><a href='https://tla.systems/blog/2009/06/'>June 2009</a></li>
	<li><a href='https://tla.systems/blog/2009/05/'>May 2009</a></li>
	<li><a href='https://tla.systems/blog/2009/04/'>April 2009</a></li>
	<li><a href='https://tla.systems/blog/2009/03/'>March 2009</a></li>
	<li><a href='https://tla.systems/blog/2009/02/'>February 2009</a></li>
	<li><a href='https://tla.systems/blog/2009/01/'>January 2009</a></li>
	<li><a href='https://tla.systems/blog/2008/12/'>December 2008</a></li>
	<li><a href='https://tla.systems/blog/2008/11/'>November 2008</a></li>
	<li><a href='https://tla.systems/blog/2008/10/'>October 2008</a></li>
		</ul>
			</section><section id="categories-2" class="widget widget_categories"><h2 class="widget-title">Categories</h2>		<ul>
				<li class="cat-item cat-item-2"><a href="https://tla.systems/blog/category/development/">Development</a>
</li>
	<li class="cat-item cat-item-52"><a href="https://tla.systems/blog/category/imposter-syndrome/">Imposter Syndrome</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://tla.systems/blog/category/uncategorized/">Uncategorized</a>
</li>
		</ul>
			</section><section id="meta-2" class="widget widget_meta"><h2 class="widget-title">Meta</h2>			<ul>
						<li><a href="https://tla.systems/blog/wp-login.php">Log in</a></li>
			<li><a href="https://tla.systems/blog/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://tla.systems/blog/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</section>	</aside><!-- .sidebar .widget-area -->

		</div><!-- .site-content -->

		<footer id="colophon" class="site-footer" role="contentinfo">
			
			
			<div class="site-info">
								<span class="site-title"><a href="https://tla.systems/blog/" rel="home">Three Letter Acronym</a></span>
								<a href="https://wordpress.org/" class="imprint">
					Proudly powered by WordPress				</a>
			</div><!-- .site-info -->
		</footer><!-- .site-footer -->
	</div><!-- .site-inner -->
</div><!-- .site -->

	<div style="display:none">
	<div class="grofile-hash-map-589648381518b2328e8bcfceb3d62708">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/tla.systems\/blog\/2019\/10\/08\/catalytic-converter\/":364};
	</script>
				<script type='text/javascript' src='https://tla.systems/blog/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.0.0'></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://tla.systems/blog/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://tla.systems/blog/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.26.0-0"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://tla.systems/blog/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://tla.systems/blog/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://tla.systems/blog/wp-includes/js/dist/dom-ready.min.js?ver=2.2.0'></script>
<script type='text/javascript' src='https://tla.systems/blog/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20190901'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201941'></script>
<script type='text/javascript' src='https://tla.systems/blog/wp-content/themes/twentysixteen/js/skip-link-focus-fix.js?ver=20160816'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var screenReaderText = {"expand":"expand child menu","collapse":"collapse child menu"};
/* ]]> */
</script>
<script type='text/javascript' src='https://tla.systems/blog/wp-content/themes/twentysixteen/js/functions.js?ver=20181230'></script>
<script type='text/javascript' src='https://tla.systems/blog/wp-includes/js/wp-embed.min.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://tla.systems/blog/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://tla.systems/blog/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/tla.systems\/blog\/wp-admin\/admin-ajax.php","nonce":"02f16b5073","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/tla.systems\/blog\/wp-login.php?redirect_to=https%3A%2F%2Ftla.systems%2Fblog%2F2019%2F10%2F08%2Fcatalytic-converter%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://tla.systems/blog/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20190102'></script>
<script type='text/javascript' src='https://tla.systems/blog/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=7.8'></script>
<script type='text/javascript' src='https://tla.systems/blog/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=7.8'></script>
<script type='text/javascript' src='https://tla.systems/blog/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=7.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://tla.systems/blog/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.8'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=201941#ver=201941' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	<script type='text/javascript' src='https://stats.wp.com/e-201941.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.8',blog:'140307013',post:'364',tz:'0',srv:'tla.systems'} ]);
	_stq.push([ 'clickTrackerInit', '140307013', '364' ]);
</script>
</body>
</html>

<!-- Dynamic page generated in 0.712 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2019-10-09 23:51:06 -->

<!-- Compression = gzip -->